Issues with phone system
Incident Report for Visma Digital Commerce
Resolved
This incident has been resolved.
Posted Mar 18, 2022 - 11:34 UTC
Investigating
We are currently experiencing some issues with our phone system. If you would like to reach us, please send us an email at support@vismadigital.com
Posted Mar 18, 2022 - 07:24 UTC